Author:Joydeep Gupta
Email:
Subject:RE: Reset PW?
Category:Need Help
Message:Following your suggestion, I tried the following. Using MySQL client, I ran the following query: "UPDATE PERSON SET PASSWORD='' WHERE Alias='SysAdmin'". The status bar displayed Rows matched: 0 Changed: 0 Warnings: 0 Then I logged into MySql Server and issued the following command. mysql> use puakma Database changed mysql> select * from Person; | PersonID | FirstName | LastName | ShortName | Alias | UserName | Password | LoginFlag | CostCenter | PublicKey | EmailAddress | LastLogin | Created | CreatedBy | LastLoginAddress | LastLoginUserAgent | Comment | | 1 | System | Administrator | SysAdmin | admin | CN=System Administrator/O=System | Pu/jV3h8bx7DrMl4cmw+2VWuiZY= | | NULL | NULL | NULL | 2003-09-01 10:59:05 | 2003-08-31 23:52:37 | System Setup | 12 7.0.0.1 | Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1) | | As per the result, the alias is 'admin' and not 'SysAdmin'. Now, I issued the following command. mysql> update person set password ='' where alias ='admin'; Query OK, 1 row affected (0.03 sec) Rows matched: 1 Changed: 1 Warnings: 0 On issuing the command below, I got the below result. Password had been set to NULL. mysql> select * from Person where shortname = 'Sysadmin'; | PersonID | FirstName | LastName | ShortName | Alias | UserName | Password | LoginFlag | CostCenter | PublicKey | EmailAddress | LastLogin | Created | CreatedBy | LastLoginAddress | LastLoginUserAgent | Comment | | 1 | System | Administrator | SysAdmin | admin | CN=System Administrator/O=System | | | NULL | NULL | NULL | 2003-09-06 11:57:15 | 2003-08-31 23:52:37 | System Setup | 127.0.0.1 | Moz illa/4.0 (compatible; MSIE 6.0; Windows NT 5.1) | | 1 row in set (0.02 sec) Again, I tried to log in as SysAdmin, without any password, but was still unsuccessful. The console displayed the following information after that attempt of mine. 06/09/2003 12:00:12: (I) 'CN=System Administrator/O=System' logged in from 127.0 .0.1 (SYSTEM - puakma.security.pmaDefaultAuthenticator) 06/09/2003 12:00:12: (I) Opened session for 'CN=System Administrator/O=System' ' 127.0.0.1' (SYSTEM - pmaSystem) 06/09/2003 12:00:12: (I) No Anonymous access is allowed to '/system/admin.pma/Lo g?OpenPage'. Requesting login (Anonymous [127.0.0.1] - HTTPRequestManager (80)) Then I shutdown the MySql server, deleted the entire Puakma database from the filesytem, started MySQL and reran the setupDB.bat once again. The system generated the following username and password. ***** FOLLOWING IS YOUR USERNAME AND PASSWORD FOR INITIAL SYSTEM ADMINISTRATION ***** UserName: SysAdmin (CN=System Administrator/O=System) Password: 121707 ***** RDBMS BUILD COMPLETE (0 errors) ***** I logged into MySql and issued the following to check the Person table. Everything seemed to have been setup properly. mysql> use puakma Database changed mysql> select * from person; | PersonID | FirstName | LastName | ShortName | Alias | UserName | Password | LoginFlag | CostCenter | PublicKey | EmailAddress | LastLogin | Created | CreatedBy | LastLoginAddress | LastLoginUserAgent | Comment | | 1 | System | Administrator | SysAdmin | admin | CN=System Administrator/O=System | /qgg84WZp/y3XbU/XQWPD+vjNBg= | | NULL | NULL | NULL | NULL | 2003-09-06 12:17:07 | System Setup | NULL | NULL | | 1 row in set (0.02 sec) Now when I launch Puakma, on the main screen, it displays 'WELCOME ANONYMOUS'. When I click the links '/system/admin.pma' or '/system/webdesign.pma', it opens the login screen prompting me to type in the user ID and password. Again same thing as before, no matter how many times I type in the system generated user ID (SysAdmin) and Password (121707), I am unable to authenticate with the server. This is what is displayed on the server console. 06/09/2003 12:48:36: (I) No Anonymous access is allowed to '/system/admin.pma/Log?OpenPage'. Requesting login (Anonymous [127.0.0.1] - HTTPRequestManager (80)) 06/09/2003 12:48:50: (I) ****** UNLICENSED EVALUATION VERSION - http://www.puakma.net (SYSTEM - pmaSystem) 06/09/2003 12:49:00: (I) 'CN=System Administrator/O=System' logged in from 127.0.0.1 (SYSTEM - puakma.security.pmaDefaultAuthenticator) 06/09/2003 12:49:00: (I) Opened session for 'CN=System Administrator/O=System' '127.0.0.1' (SYSTEM - pmaSystem) 06/09/2003 12:49:00: (I) No Anonymous access is allowed to '/system/admin.pma/Log?OpenPage'. Requesting login (Anonymous [127.0.0.1] - HTTPRequestManager (80)) 06/09/2003 12:49:39: (I) 'CN=System Administrator/O=System' logged in from 127.0.0.1 (SYSTEM - puakma.security.pmaDefaultAuthenticator) 06/09/2003 12:49:39: (I) Opened session for 'CN=System Administrator/O=System' '127.0.0.1' (SYSTEM - pmaSystem) 06/09/2003 12:49:39: (I) No Anonymous access is allowed to '/system/admin.pma/Lo g?OpenPage'. Requesting login (Anonymous [127.0.0.1] - HTTPRequestManager (80)) It does not display anything like the information pasted below as mentioned in your response earlier. 02/09/2003 07:21:40: (I) Access is denied for 'test' from 127.0.0.1. Check the password and try again (SYSTEM - puakma.security.pmaDefaultAuthenticator) 02/09/2003 07:21:40: (E) There was no authenticator capable of authenticating 'test' (SYSTEM - pmaSystem) Okay, I think I have tried to provide you with as much information as I possible can. Now, is there anything very stupid and obvious that I am missing or not doing, which is preventing me from loggin into the system. Appreciate your help.

Threads:
Unable to log in.   Anonymous 02.Sep.03
    Case-sensitive RDBMS?   Brendon Upson 02.Sep.03
        RE: Case-sensitive RDBMS?   Anonymous 02.Sep.03
    Reset PW?   Tim Stevens 03.Sep.03
        RE: Reset PW?   Joydeep Gupta 07.Sep.03
            Browser cookies enabled?   Brendon Upson 08.Sep.03
                RE: Browser cookies enabled?   Joydeep Gupta 09.Sep.03
                    Changing session ID   Brendon Upson 09.Sep.03
                        RE: Changing session ID   Joydeep Gupta 10.Sep.03